Схема базы данных

Всегда полезно иметь под рукой актуальную схему вашей базы данных. Поверьте, пройдет время и вам будет сложно понять как объекты связаны друг с другом. По конфигуратору это сделать сложно. Всегда создавайте схему базы до ее реализации в конфигураторе. Создайте хотя бы схему из основных объектов, реализуйте ее в конфигураторе, а затем дополняйте на схеме и в конфигураторе одновременно. Постоянно поддерживайте актуальность схемы базы данных.

Пример схемы базы данных

Для рисования различных схем и диаграмм есть замечательная программа yEd. Среди преимуществ следует отметить легкость построения диаграмм и автоматическое выстраивание объектов и связей, чтобы схема базы выглядела наглядно. Важно, чтобы родительские объекты были выше чем дочерние, так схему легче "читать".

Настройки по умолчанию

  • Тип связи по умолчанию. Дважды щелкните по связи как на картинке. Теперь у вас эта связь будет использоваться по умолчанию. Данный вид связи наилучшим образом выглядит при автоматическом выравнивании объектов, о котором речь пойдет ниже.
    Выбор связи по умолчанию
  • Автовыравнивание ширины объекта по его подписи и редактирование объекта при его создании.  Меню File - Preferences, вкладка Editor.
    Настройки программы

Советы по рисованию схем баз данных

Объекты и справочники разным цветом

Справочники лучше рисовать белым цветом, чтобы они меньше привлекали к себе внимание.
Объекты и справочники разным цветом

Чтобы изменить цвет объекта:

  1. Выделите объект.
    Выделите объект
  2. В окне Properties View измените свойство Fill Color.
    Изменение цвета

Связи между объектами

Связи рисуйте как вороньи лапки, чтобы было понятно, где дочерний объект. Стрелки не так понятны.
Куриная лапка

Чтобы изменить стрелку на воронью лапку:

  1. Выделите связь.
    Выделите связь
  2. В окне Properties View измените свойство Target Arrow.
    Изменение стрелки связи

Чтобы использовать нужный вид стрелки по умолчанию (чтобы была всегда воронья лапка):

  1. создайте одну такую связь между объектами,
  2. с правой стороны в окне "Current Elements" дважды щелкните по связи,
    Вид связи по-умолчанию
  3. она выделится и всегда будет такой по умолчанию.

Выравнивание схемы объектов

Чтобы красиво выровнять объекты и связи выберите в меню Layout - Hierarchical. Единственное, что здесь стоит поменять, это Routing Style, чтобы объекты по вертикали не были слишком близко друг к другу.

Стиль соединения объектов

Экспорт в формат png

Для публикации схем в нашем форуме экспортируйте ее в формат png. В меню File выберите Export, измените формат на png и сохраните файл.

Экспорт в png

  • Нравится
  • Google+